Page 1 of 2

phpBB problem

Posted: Oct 4th, 2006 at 10:28 am
by rekloose-[PUPPY]
k2, ever since you upgraded the message forum i can't get it to "remember" me. I've deleted all my HF cookies and it's still not working - makes me log in every time. any ideas?

Re: phpBB problem

Posted: Oct 4th, 2006 at 11:29 am
by Burzum
rekloose-[PUPPY] wrote:k2, ever since you upgraded the message forum i can't get it to "remember" me. I've deleted all my HF cookies and it's still not working - makes me log in every time. any ideas?


Me too. It's a PITA.

Posted: Oct 5th, 2006 at 2:17 am
by rekloose-[PUPPY]
k2 .. help?

Posted: Oct 5th, 2006 at 3:40 pm
by G$
I thought it was just meh

G$

Posted: Oct 5th, 2006 at 5:27 pm
by Oreo
Was going to make a thread on this too. Guess it's not only me. Have to login almost everytime I come to the website. Old one saved until I deleted cookies. :(

Posted: Oct 5th, 2006 at 5:39 pm
by Jeng
I been fine, wonder what the difference is?

Might want to give K2 some information, guess ya'll would know what information he needs, I don't.

Posted: Oct 5th, 2006 at 5:41 pm
by Oreo
I just use internet explorer. The page is fine if I don't close the window. I can load up other sites, then go back to HF and my account stuff is still there. Once I close the window, bam, next time I come back to the site whether 20 seconds from then or tomorrow, I have to log in again (even with I check the box to "remember me").

Posted: Oct 5th, 2006 at 6:11 pm
by rekloose-[PUPPY]
me too oreo ...

Posted: Oct 5th, 2006 at 7:09 pm
by b0ba
i use ie and it forgets me too

Posted: Oct 6th, 2006 at 1:28 pm
by Jeng
Thats weird, first time I've had to log in in quite awhile. So after doing some reading, then posting, I closed my browser, then opened it back up and I was still logged into HF. /shrug

Posted: Oct 6th, 2006 at 3:14 pm
by K2
I'm aware of this issue gang. It happens to me as well, but rarely... maybe once out of every 20-25 times that I visit the msgboard.

I'm gonna increase the cookie session time, see if that helps any.

Posted: Oct 6th, 2006 at 3:42 pm
by G$
I have IE7 installed on my work pc, and IE6 on my laptop and desktop at home. IE 7 has not remembered me since your switch. IE6 on my laptop remembers like it always has, and does sometimes but not others on my desktop. In other words, it makes absolutely no sense.

Posted: Oct 6th, 2006 at 4:45 pm
by WidowMaker
I use Firefox, and I have to re-login about once a day, so maybe 1 out of every 10-15 visits.


-Wid

Posted: Oct 9th, 2006 at 6:31 am
by rekloose-[PUPPY]
K2 wrote:I'm aware of this issue gang. It happens to me as well, but rarely... maybe once out of every 20-25 times that I visit the msgboard.

I'm gonna increase the cookie session time, see if that helps any.


hasn't changed anything for me ... having to log in all the time is really getting annoying.

Posted: Oct 9th, 2006 at 6:50 am
by K2
Try killing all your cookies, closing your browser, and try again puppy. I know you dont use IE or FF; your browsers cookie handling may very well be flawed when it comes to accepting/remembering cookies thru an iframe.

I am having *minimal* problems with IE6 - in fact, after raising the session timeout value, and cleaning up the session table in the msgboard database, the issue happens less often now (at least on IE6).

Posted: Oct 9th, 2006 at 10:06 am
by rekloose-[PUPPY]
i use IE6. I've killed my cookies a few times to no avail.

Posted: Oct 9th, 2006 at 10:27 am
by Phoenix
This is all very odd, I use FF and have had no issues at all

Posted: Oct 9th, 2006 at 1:09 pm
by Jeng
Phoenix wrote:This is all very odd, I use FF and have had no issues at all


Watch out, I said the same thing, then it began............

Posted: Oct 10th, 2006 at 9:18 am
by KillerClown
I've been switching up a lot between IE6, IE7, and FF lately. IE7 is the only one that HF doesn't remember me on, I also have a few other issues with IE7, which I won't detail because they aren't relevant to this. But I get the same thing with my clans forums and IE7.

Also IE7(B2) is different for me than IE7(RC1), both of which have their issues. One of the prior-to-beta IE releases I picked up a while back wouldn't even show the content of my clans forums, I would load up the page and see everything except the forum (category) listings.


I never have to login to HF with FF though, only with the newer IE releases. Same with any forums I've visited, IE just doesn't like to restore sessions (or whatever). :O

Posted: Oct 10th, 2006 at 2:32 pm
by Oreo
Seems fixed for the most part. I have to log in a lot less now.

Posted: Oct 10th, 2006 at 3:47 pm
by Burzum
Still happens to me. :(

Posted: Oct 10th, 2006 at 9:11 pm
by K2
I've been looking online for a script that will properly do a hand-off of a session cookie to whatever browser thru an iframe. Apparently it's an issue, but it's not just dependent on what browser the end-user is using, it's also dependent on 1) how the site is coded and with what language (here it's php) and 2) how the web server itself is configured (which I have limited direct access of).

The most threads I've found on the subject involve IE 5+ and asp/aspx, which unfortunately doesnt apply here.

If ya'll could help me research it (IE/FF/Opera front-end/PHP scripting/Apache+Linux back-end), that'd be great. I'll probably hit up my web host via their trouble ticket system, see what they say.

Posted: Oct 11th, 2006 at 1:38 am
by rekloose-[PUPPY]
so this is about the iframe?

Posted: Oct 11th, 2006 at 2:37 am
by K2
K2 wrote:I've been looking online for a script that will properly do a hand-off of a session cookie to whatever browser thru an iframe...

Posted: Oct 11th, 2006 at 7:38 am
by rekloose-[PUPPY]
but i don't think the problem is a session cookie. session cookies are destroyed when a browser closes the connection. the problem is the persistent cookie that stays on your HD after the browser/connection has been closed.